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Introduction
Grab-a-Site is a powerful Internet tool that allows you to grab complete sections of the World Wide
Web. When you grab a site, it is downloaded onto your hard drive where you can surf without costly
Internet charges. You can tell Grab-a-Site specifically which sites to grab using the Include filter.
Filter out any unwanted sites with the Exclude filter.
The new Grab-a-Site 5.0 can get specific file types from a site. If you want all the PDF files, just
enter "PDF" during the Add URL Wizard. Download all the images, zip files, movies. Whatever you
want to grab and keep.

2

Installation
Installing Grab-a-Site is very easy. Insert the CD, choose Grab-a-Site, and click on INSTALL. You
will be prompted for the location to install the program. We suggest you accept the defaults.

2.1

Requirements
·
·
·
·
·

2.2

486 or faster processor
Windows 95/98/NT/Me/2000/XP
16 MB of RAM
At least 6 MB hard drive space
A working Internet connection

Installation Summary
The installation setup program is called Grab-a-Site5Setup.exe. You must run the setup
program to install Grab-a-Site to your hard disk (Product installation is found in section
"Loading the CD"). Here's a summary of what the setup program does:
·
·

Copies the Grab-a-Site files to your hard disk.
At the end of the installation process Grab-a-Site presents you with the option to view
the README.TXT. We recommend looking this document over because it contains
more information about Grab-a-Site.

When you first start Grab-a-Site, the InstantX registration dialog box will appear. To fully
enable your copy of Grab-a-Site please fill out the form and enter your VIP Key, and then send
it electronically to Blue Squirrel. If you don't register Grab-a-Site, the InstantX dialog box
will pop up each time you run the program, and it will run as an evaluation program. Once
you have purchased the program and entered your VIP key, you'll see your License Key code
in the About Grab-a-Site box.
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Loading the CD
1. Insert the CD into the appropriate disk drive.
2. The CD should automatically load. If the CD does not load automatically, double click
on the "My Computer" icon on your desktop. Select your CD drive, go to File on the
menu bar and click Open. Find the file named BlueSquirrelInstaller.exe and double
click. An introduction screen will appear.
· Click on the program you would like to install on the left.
· If you wish to purchase the product click on the BUY text. This will take you
to the Blue Squirrel Web purchase page for that product.
· To demo the product click on the title or on the INSTALL text.

2.4

UnInstalling
To Uninstall Grab-a-Site, go to your Control Panel and choose Add/Remove Programs. Then choose
Grab-a-Site, and hit the Change/Remove button.

3

Getting Started

3.1

Registering Electronically
Even if you have not purchased the program, we politely request that you register the program before
using the trial version. The registration box will appear when you run the program and have not
registered. Please ensure that you have an active Internet connection, enter your information, and hit
OK. Your information will be sent electronically.

3.2

Registering Manually
Access the InstantX Registration Screen by selecting Help->About-> InstantX, and then the Settings
tab from the Grab-a-Site Menu Bar. Enter in your customer information, and your VIP key and then
select the Print button to print the form instead of sending it over the Internet.
Fax the printout to us at 801-912-6032, or send it via post mail to:
Blue Squirrel
Attn. Customer Service
686 E. 8400 South
Sandy, UT 84070

3.3

Purchasing the Program
Grab-a-SiteThere are many ways to purchase the program. The easiest way is to hit the "Purchase
Online" button that will appear each time your start the trial version. You may also
call to order the program. We accept all major credit cards.
Once you have purchased the program you will be given a VIP Key. The VIP Key is an activation
code to activate the program and remove any trial limitations.
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Activating Grab-a-Site
Make sure you have an active connection to the Internet so you can submit your registration online.
The first time you run Grab-a-Site, the InstantX Registration dialog box appears. Select Help->About>InstantX button.
Enter in your customer information, and VIP key, and press OK to submit your information over the
Internet.
Your VIP Key looks like this:

GASR-ABCEFG-LKJIH-MNO-UTSRQP

4

Using Grab-a-Site
Grab-a-Site is project based. You set all the settings for the project and then you can save the project
to run it again and again.
The steps:
1. Create a Project
2. Add a URL
3. Set Properties (optional)
4. Start grabbing
5. View Contents Page

4.1

Create a Project
When you first open Grab-a-Site, you will be asked whether you want to create a new project or open
an existing project.
You can also create a new project by choosing File -> New Project.
You will need to choose where to store your project file. A folder will be created with the same name
which will contain all of the downloaded files, and the required databases.

4.2

Adding a URL
There are several ways to add a URL. The URL Wizard is the easiest and will walk you through the
two simple steps. When adding a URL, you must limit Grab-a-Site so that it does not try to download
the entire web.
You can also drag a URL link from Internet Explorer to Grab-a-Site to start the URL Wizard.

© 2003 Blue Squirrel
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Add URL Wizard

The URL Wizard will step you through adding a new URL.
Enter the URL where you want to start, and choose whether you want to remain on the site, or in the
directory.
Remain On Site - Will only follow links in the same domain.
Remain in Directory - Will only follow links if they have the same directory as the URL you entered.

Choose how many levels. See the Glossary for a definition of a level.

© 2003 Blue Squirrel
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You can exclude certain types of data so that you are not downloading very large files that you may
not need or want.
You can also choose to download ONLY certain types of files. This is great for culling images, getting
just PDF files, or just movie files.

Choose when to start. If you leave the default of 'Immediately after this wizard', then Grab-a-Site will
begin downloading as soon as you hit next. If you choose 'Later' because you are not online, or you
want to add more URLs, you will hit the Go button to start the download.

4.2.2

Import URL(s)...
You provide Grab-a-Site with a text file full of URLs, or an HTML file with links. Grab-a-Site will add
all of the URLs from the text file, or all of the URLs from the links in the HTML file.

© 2003 Blue Squirrel
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Grabbing
Hit the
button to begin grabbing web sites. Grab-a-Site will follow all of the links and get the files
and put them in a folder.
The folder will have the same name as the project. If your project is joe.gas, then the folder with the
files will be joe\src. If you have Use Domain in Directory turned on, there will be additional folders.
If you have the Grab Status window turned on, you will see the pages that are pending, and how
much data has been sent and received, and how many simultaneous connections (Threads) that the
program is using.

4.4

Refresh
To refresh a project, hit the
button. Refresh is the same as Grabbing, except that it will ask the
server to send the page again if it has been modified since the last time it was grabbed. It will also
resume grabbing if the previous grab was stopped early. If new links have been added to recently
changed pages, those will be followed also (subject to the project's filters).

4.5

Contents Page
The contents page is automatically written by Grab-a-Site when the project finished Grabbing. The
page has links to all the pages you've added.
You can edit head.htm and foot.htm in the program directory. head.htm will be added before
the links, and foot.htm will be added after the links. This allows you to fully customize the
contents.htm page to your liking. Our sample head.htm and foot.htm files have some simple
formatting and a style sheet that you can use as a starting point.
The Title you set in Grab-a-Site will be used when the contents.htm file. You can modify the to title to
name your grabbed web sites.

4.6

Grab-a-Site Options
Grab-a-SiteGrab-a-SiteThe Grab-a-Site options apply to all projects.
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You can set the browser and editor that Grab-a-Site uses when launching pages.

© 2003 Blue Squirrel

9

10

Grab-a-Site 5.0 User's Guide

Maximum Threads - The number of active connections Grab-a-Site will use when downloading
pages and graphics.
Maximum Threads Per Server - The number of active connections Grab-a-Site will use when
downloading pages and graphics from a single server. You should keep this limited so it does not bog
down someone's server with too many simultaneous active connections.
Maximum Bytes to Grab (in Kilobytes) - This limits the amount of data that Grab-a-Site will get
during a Grab or a Refresh.
Maximum Amount of Time to Grab (HH::MM) - Limits the amount of time that Grab-a-Site will work
when you hit Grab or Refresh.
Use Domain in Directory - Stores the files for each site in a different directory. For example: If you
were getting http://www.ibm.com, the files would be stored in an ibm.com subdirectory, while the files
from http://www.visa.com would be in the visa.com subdirectory.
Preserve Site Structure - Store the files in a subdirectories which mirror the directory in the URL.
For example, the page from http://www.ibm.com/goodies/page.htm would be stored in a ...\goodies
subdirectory on your hard drive.
Use MS-DOS 8.3 Filenames - Creates 8.3 filenames from the online page names. This can be used
for backwards compatibility with the oldest of systems.
User Agent - Lets you set how Grab-a-Site reports itself to the web servers. By default, it sends
"Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1.)" which makes it look like an Internet Explorer
version 6.0.

© 2003 Blue Squirrel
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If you connect through a Proxy server, you should set Use Browser's Proxy Settings which will get
the settings from your Internet Explorer's settings. Most users will not need to set this information.

4.7

Project Properties
You can set certain properties that apply to the project. Go to File->Project Properties.

You can run a program after you finish grabbing the files. By default, it runs your browser with a
© 2003 Blue Squirrel
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special contents.htm page it builds from the top-level URLs you've added.
This can very useful for running a post-processing program like language translation, a spell checker,
a link verifier, an ftp transfer, etc.
Replace Tab

You can do an automatic search and replace. This can be useful to remove scripts, fix up errors on
the original site, replace relative URLs with absolute URLs when necessary, etc.

Edge Links
Edge links are links that were not grabbed because the links were not part of the site, or the links are
beyond the number of levels specified, or the links were excluded because of the filters you have set
for the project.
By default, Grab-a-Site will set links to ungrabbed pages to their absolute URL reference so that they
will work from a CD if the user is online. You can change the edge page to any fixed URL or file
you'd like. If you set the URL to an absolute URL reference, it will be the same URL for every
© 2003 Blue Squirrel
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ungrabbed page. You can also set it to a file like edge.htm and Grab-a-Site will copy all files from the
Grab-a-Site\edge directory when it exports the site.

4.8

URL Properties

You can get to URL Properties by choosing Edit->URL Properties..., or right click on a URL and
choose URL Properties.
If it is a URL that you added, you can change the URL. The Title is extracted from a successfully
downloaded page. The folder is the location of the page on your hard drive. The file is the name of
the file, which won't always match the original because the filenames must be unique.
You can change the number of levels that Grab-a-Site will follow by changing the Levels. It will apply
from that URL and down.
If you Skip this URL, it will not follow any links from that URL during a Grab or Refresh.
You can browse to the directory by hitting the Browse button, and you can Launch the page in your
browser by hitting the Launch button.

© 2003 Blue Squirrel
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You can set filtering options for each URL. If the filtering options are not set, the URL will inherit the
options from its parent. If you do set it, it will be in effect for that URLs links and down.
Remain in Site - will keep Grab-a-Site in the original domain, with one exception. If you enter
www.domain.com, then it will follow other *.domain.com links. If you use store.domain.com, then only
store.domain.com links will be followed.
Remain in Directory - will keep Grab-a-Site from straying from the directory. If you entered
http://www.domain.com/support/index.html, then only those pages in the /support/ directory will be
followed.
Exclude - will quickly set up filters to exclude certain types of files by their reported MIME tag.
Use the powerful Advanced Filter if you need very fine control of what is included or excluded.
Only download these types of files will throw away the HTML pages after it follows the links looking
for the type of files that you want. This feature would let you get all the .PDF files from a site for
example. This is one of the very unique features of Grab-a-Site which lets you get all the graphics
from a site, or all the PDF files, or all the programs, etc.

© 2003 Blue Squirrel
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If the site you are visiting requires a password, enter it here. This only works if the site uses browser
based authentication. The sites where the password is entered directly on the page will not work.
Use the Notes tab to enter notes about the URL.

© 2003 Blue Squirrel
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Advanced Filter

The Advanced filter is extremely powerful, and will let you get almost any combination of pages or file
types.
Stay On Site - A simple check box that adds the domain inclusion filter.
Stay In Directory - A simple check box that adds the directory inclusion filter.
Document Size - Excludes files that are over a certain size, provided the web server supplies the
Content-Length header.
Some of the things you can do with filters:
· Exclude portions of a web site by not getting pages in a certain directory.
· Get only certain areas of a web site by including only certain directories.
· Keep ads from being downloaded by excluding links to doubleclick.com and other ad engine sites.
· Keep certain types of files from being downloaded to save time and bandwidth.
You can add new filters based on MIME type or URL. Using URL, you can include/exclude by
domain, directory, file, or by file extension.

© 2003 Blue Squirrel
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You can filter based on the URL or MIME type.
You can Include or Exclude based on the filter.
Kept - Keeps the file.
Discard - Does not download or keep the file, unless it is an HTML link that it needs to
Enter the text to match and how to match the text.
Some examples:
· If you are filtering by file extension, enter ".exe" and check "End with the above text"
· If you are filtering by directory, enter "/somedir/" and check "Contain the above text"
· If you are filtering by domain, enter "http://www.somesite.com/" and check "Begin with the above
text"

4.9

File Location
You can save the .GAS file wherever you'd like. A folder will be created with the same name (without
the extension). This newly created folder will contain all of the files that you grab, and some database
files that are necessary for Grab-a-Site to keep track of where it has been and not go into a loop.
Example:
C:\Temp\MySite.GAS - Your original .GAS file
C:\Temp\MySite\ - Folder where all the files for the MySite project are stored.
C:\Temp\MySite\GS*.DBF - Databases that Grab-a-Site uses to track where it has been.
C:\Temp\MySite\src\ - Location of html files
C:\Temp\MySite\src\www.somedomain.com\ - Location of files from http://www.somedomain.com if

© 2003 Blue Squirrel
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"Use domain in directory" is set.
C:\Temp\MySite\src\www.somedomain.com\somdir\ - Location of files from
http://www.somedomain.com/somedir/ if "Preserve Site Structure" is set.

4.10

Export

Export will copy all of the essential files to a new location.
Example uses:
· Copy them to a network location so that students can use the files.
· Copy them to a removable disk for archival.
· Copy them to a new web server.
· Copy them to a temporary location so they can be burned onto a CD.
· Copy them to a floppy disk.
If you check Autorun.inf, additional files will be added so the CD will automatically run and the
contents page will be launched when in the CD is inserted into a Windows computer.
Requirements for Autorun:
· The files must be burned to a CD ROM or CD R/W
· The Autorun.inf, and contents.htm must be in the root directory of the CD

5

Menu and Toolbar
Enter topic text here.

5.1

File
New Project - Creates a new project
Open Project - Opens an existing project
Project Properties - Set Project Properties
View Contents - Launches the generated contents.htm page
Import URL(s)... - Reads in a list of URLs from a text file or links from an HTML file
Export Content - Copies web pages, graphics, etc to a new location
<Project> - Opens a previous project
Exit - Exits Grab-a-Site

5.2

Edit
URL Properties - Opens the URL Properties dialog
Insert (INS) - Adds a new top level URL to the project
Delete (DEL) - Removes the selected top level URL from the project
Cut - Removes the selected top level URL from the project - puts URL on clipboard
Copy - Copies the URL to the clipboard
© 2003 Blue Squirrel
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Paste - Pastes a URL from the clipboard to Grab-a-Site and starts URL Wizard

5.3

View
Toolbar - Turns the toolbar on and off
Status Bar - Turns the status bar on and off
Grab Window - Turns the Grab Status window on and off

5.4

Tools
Start Grabbing - Starts the grabbing process.
Start Refresh - Refreshes URLs that have been grabbed already, and resumes a stopped grab.
Stop Grabbing - Stops the grabbing process.
Program Options... - Lets you set the Grab-a-Site Options.
Update
Update Now! - Updates the program to the latest version.
Undo Last Update... - Reverses the last update to restore the program to its previous version.
Update Settings... - Set the update settings (frequency, etc.)

5.5

Help
Help Topics - Launches the Help file
Register... - Lets you register the program and set VIP Key
About... - Provides version information and company information

5.6

Toolbar
- New Project
- Open Project
- Start Grabbing
- Refresh
- Stop Grabbing
- URL Properties
- Add URL
- Delete URL
- Cut
- Copy
- Paste
- Icon View
- List View
- Details View
- Launch the Contents Page
- Visit Blue Squirrel

6

Right-Click Menu
You can select items and right-click to get additional options that apply to that URL or item.

© 2003 Blue Squirrel

20

6.1

Grab-a-Site 5.0 User's Guide

URL Properties
See URL Properties

6.2

Grab URL
Begins grabbing the selected URL.

6.3

Refresh URL
Begins refreshing the selected URL.

6.4

Browse Local
Launches your browser and loads the local (hard drive) version of the file.

6.5

Browse Remote
Launches your browser and takes you to the Internet version of the URL.

6.6

Skip URL
Selecting this will set the URL to be skipped when grabbing. This is great when you want to grab
portions of a site. You can grab the first level and then skip all the sections you don't want.

6.7

Delete URL
Will delete the selected item. You can also hit the [DEL] key. The option is only available for URLs
you've added ("root URLs")

6.8

Edit HTML File
Launches an editor with the file. You can set your favorite editor with Program Options.

6.9

Export URL Tree
Exports the web site from that URL and down.

6.10

Export URL Page
Exports that page and its graphics.

7

Advanced

7.1

Hot Keys
INS - Add a URL
[DEL] - Delete currently selected item. You can only delete URLs you've added ("root URLs")

7.2

Command Line Options
One of the unique features of Grab-a-Site is the ability to use it as a command line utility to get files.

© 2003 Blue Squirrel
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All command line options apply only if a project is also specified on the command line.
/a<url> Add URL
/i<file> Import URL's from file
/u
/e

Unattended - start grabbing
Exit after finishing unattended grab

These apply to new URL's (/a or /i)
/c
StayOnSite on
/c0
StayOnSite off
/c1
StayOnSite on
/l
All Levels
/lx
Go x Levels
Example:
GrabSite.exe C:\TEST\TEST.GAS /ahttp://www.ibm.com /l2 /c1 /u /e
This would grab IBM's site two levels, and would stay on site so if IBM had a link to lotus.com it
wouldn't be followed.

7.3

Hidden Options
In your project file (.gas), you can modify what Grab-a-Site uses for the Shell command. You would
only change this if you are running programs after the Grab, and the shell command is not right for
your operating system.
[GAS]
Shell=command.com /c

8

Customer Support
The User's Guide will supply most of what you need to know to be productive with Grab-a-Site. Below
we have listed several options to choose from to assist you with any help you may need using Graba-Site. Additional information about Grab-a-Site can be found in the README file.

8.1

Help File
To access the Grab-a-Site help file, click Help > Help Topics. We encourage you to use Grab-a-Site
help, because it's a complete, informative reference system. In addition, Help offers several
advantages over the printed manual.
In the Help Index, you can type in a keyword, and the program automatically looks it up for you.
While reading the Help file you can click on a "hot" phrase to jump to a related topic. And later you
can retrace your steps; flipping backwards through the topics you jumped from. Or you can read
topics in order, like turning the pages of a book, either forward or backward.

8.2

Web Site
Program Web Site:
http://www.bluesquirrel.com/products/Grab-a-Site

© 2003 Blue Squirrel
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If you cannot find the information you need at the program web site, try our FAQs located in our
Technical Support area for assistance.
http://www.bluesquirrel.com/support/

8.3

Technical Support
Our web based technical support and Frequently Asked Questions can be found at:
http://www.bluesquirrel.com/support/

8.4

Customer Service
You're more than welcome to contact us via telephone. If you would like to speak with a Blue Squirrel
representative regarding non-technical issues please select from the following options:

Phone: 801-352-1551
Toll Free: 800-403-0925
Fax: 801-912-6032
E-mail: sales@bluesquirrel.com
Hours are: Monday through Friday, 8:00 a.m. to 5:00 p.m. Mountain Time.

8.5

Mailing Address
Blue Squirrel
686 E. 8400 South
Sandy, UT 84070

9

Glossary
Directory - The part of a URL that identifies the location of the file in the web folders. In
http://www.ibm.com/help/page.html, help is the directory.
Domain - The part of a URL that identifies the computer. In http://www.ibm.com/help/page.html,
www.ibm.com is the domain.
Edge Pages - The edges are links that are not followed because they don't match the filter, or they
are on a different site, or because they are going to level four when the program is told to stop at level
three.
Levels - The number of clicks it would take to get to a page. If you enter a URL, and specify one
level, it will only get that page. If you specified two levels, it would get that page and everything it
links to. If you specified three levels, it would get that page, everything it links to, and everything
those pages linked to. If you specified four levels... Well, you get the picture.
MIME type - A text identifier that is sent with web pages that identify the type of file. It might be
text/plain, text/html, application/exe, etc.
Page - The part of a URL that identifies the file. In http://www.ibm.com/help/page.html, page.html is
the page.
URL - A Uniform Resource Locator, sometimes known as a link. http://www.ibm.com/help/page.html
is a URL.
© 2003 Blue Squirrel

Index

Grab-a-Site Options

Index

-H-

-A-

Help File

Activation 5
Advanced Filter

21

-I-

16

Installing 3
Installing from the CD
Introduction 3

-BBlue Squirrel Location 22
Browse Local 20
Browse Remote 20
Browser Emulation 8
Buying the program 4

-C-

4

-LLevels 22
License Key

5

-M-

CD 4
Customer Service

Mailing Address
MIME type 22

22

-D-

-P-

Delete URL 20
Directory 22
Domain 22

Page 22
Project Properties

22

11

-R-

-EEdge Pages 11
Edit HTML File 20
Electronic Registration
Export 18
Export URL Page 20
Export URL Tree 20

-F-

4

Refresh URL 20
Remain in Directory 6
Remain On Site 6
Removing the program 4
Requirements 3
Right-Click Menu 19
Run After 11

-S-

Fax Registration
Filter 13

-GGrab URL

8

20

© 2003 Blue Squirrel

4

Search and Replace
Set Filter 13
Site Structure 8
Size 8
Skip URL 20

11

23

24

Grab-a-Site 5.0 User's Guide

-TTechnical Support 22
Threads 8
Threads per Server 8
Time 8

-UUnInstalling 4
URL 21, 22
URL Properties
User Agent 8

13

-VVIP Key

5

-WWeb Site

21

© 2003 Blue Squirrel

